学破解论坛

 ★找回密码★
 ★免费注册★

QQ登录

绑定QQ,免密登录

查看: 443|回复: 3

求个给加VMP壳打补丁的源码或方法

[复制链接] |关注本帖

签到天数: 8

该用户今日未签到




30HB
最进破解的E盾+VMP的DLL 有二次验证 日了以后不能保存 。。。所以
问题来了
加VMP壳的DLL怎么打补丁呢
emmmmmm  大佬们 救我

学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 108

该用户今日未签到

回复

使用道具 举报





.版本 2

.DLL命令 GetModuleHandleA, 整数型, "kernel32.dll", "GetModuleHandleA", 公开, API取模块句柄
    .参数 a, 文本型

.版本 2

.局部变量 基址, 整数型
.局部变量 补丁地址, 整数型
.局部变量 偏移, 整数型

基址 = GetModuleHandleA (“dll名字”)
补丁地址 = 十六到十 (“补丁地址”) - 基址
补丁地址 = 基址 + 补丁地址
' ----------------------
' 写到内存 (补丁数据, 补丁地址, 字节集长度)
' ----------------------
' 这里就可以直接写补丁了
' 偏移是你的补丁地址减去基址就是你的补丁地址了

.子程序 十六到十, 整数型, 公开, 将十六进制转换成十进制(返回十进制文本)
.参数 十六进制文本, 文本型, , 待转换的十六进制文本
.参数 返回结果, 文本型, 参考 可空, 返回文本结果(如十进制数超出整数范围,可通过返回结果获得十进制文本)
.局部变量 中间文本, 文本型
.局部变量 结果, 长整数型
.局部变量 容器1, 整数型

返回结果 = “”
十六进制文本 = 到大写 (十六进制文本)
十六进制文本 = 子文本替换 (十六进制文本, “0X”, , , , 真)
.变量循环首 (1, 取文本长度 (十六进制文本), 1, 容器1)
    中间文本 = 取文本中间 (十六进制文本, 容器1, 1)
    结果 = (寻找文本 (“0123456789ABCDEF”, 中间文本, , 真) - 1) × 求次方 (16, 取文本长度 (十六进制文本) - 容器1) + 结果
.变量循环尾 ()
.如果真 (是否为空 (返回结果) = 假)
    返回结果 = 到文本 (结果)
.如果真结束
返回 (结果)
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 8

该用户今日未签到

回复

使用道具 举报




涛涛 发表于 2019-9-21 23:24
.版本 2

.DLL命令 GetModuleHandleA, 整数型, "kernel32.dll", "GetModuleHandleA", 公开, API取模块 ...

大佬 能给个源码吗 万分感谢
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 156

该用户今日未签到

回复

使用道具 举报




少直接要源码,路都是自己走出来的
ZwProtectVirtualMemory
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!
您需要登录后才可以回帖 登录 | 立即注册

获得更多积分,阅读本版加分规则

免责声明

本站中所有被研究的素材与信息全部来源于互联网,版权争议与本站无关。本站所发布的任何软件的逆向分析文章、逆向分析视频、补丁、注册机和注册信息,仅限用于学习和研究软件安全的目的。全体用户必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。学习逆向分析技术是为了更好的完善软件可能存在的不安全因素,提升软件安全意识。所以您如果喜欢某程序,请购买注册正版软件,获得正版优质服务!不得将上述内容私自传播、销售或者其他任何非法用途!否则,一切后果请用户自负!

站长邮箱:SharkHeng#iCloud.com


站长微信号:SharkHeng|联系Email|鲨鱼逆向|无图版|手机版|小黑屋|FAQ|VIP破解教程|学破解论坛 ( 京公网安备 11011502002737号 | 京ICP备14042738号 ) 

GMT+8, 2019-12-13 16:26

快速回复 返回顶部 返回列表