学破解论坛

 ★找回密码★
 ★免费注册★

QQ登录

绑定QQ,免密登录

查看: 5576|回复: 92

[原创逆向图文] 悬赏杀手-PEAS云伪造标准DLL带源码

  [复制链接] |关注本帖

签到天数: 9

该用户今日未签到




悬赏帖子:
不知道是否能叫变态程序 各种补丁无效 技穷了 求思路 PEAS云验证
(出处: 学破解论坛)

DLL源码参考:
PEAS云验证破解之伪造DLL
(出处: 学破解论坛)


QQ图片20150605023855.png

有幸能被选为最佳收了200HB当然要为楼主解决问题
由于原帖被关闭我的用户组权限又不能发私信所以单独开帖子@cydzdiy

使用原帖的源码编译DLL出现下标越界的原因是有个函数的返回值没有做修改,参照官方DLL的返回格式改一下就解决了

  1. .版本 2

  2. .子程序 POST, 文本型, 公开
  3. .参数 shorturl, 文本型
  4. .参数 httpverb, 整数型
  5. .参数 inputparams, 文本型

  6. .如果真 (shorturl = “uinfo”)
  7.     返回 (“0.00::0::0::0::10::2015-06-01 18:17:12::2099-06-05 12:00:00::0::备注”)  ' 消费金额::剩余点数::已用点数::限时长分钟::登录次数::上次登录时间::到期时间::已绑机1是0不是::备注
  8. .如果真结束

  9. 返回 (“1”)  ' 返回值为1 表示成功  '如果需要特殊的返回 只要判断参数 shorturl在进行返回即可
复制代码
游客,当前主题有一部分内容已经设置隐藏,需要回复才能查看全部内容。


评分


每日系统赠送“免费评分”
评分不仅是免费的,还能提升你自己账号的活跃度。既感谢了楼主,又提升了自己。可谓一箭双雕!何乐而不为?评分安排上!

参与人数 17威望 +1 HB +56 THX +17 收起 理由
bianyuan456 + 1 软件带有“学破解论坛网址”,+20HB,置顶高亮7天7夜!
tyfjmll + 1 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!
自然卷。 + 5 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!
幼稚园杀手 + 3 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!
yaozi520be + 1 好人有好报!你的热心我永远不忘!谢谢!
有何不可 + 2 + 1 评分=感恩!简单却充满爱!感谢您的作品!
ningzhonghui + 2 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!
cydzdiy + 5 + 1 再次感谢热心帮助解答疑难 !
菜鸟中的菜鸟 + 5 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!
Shark恒 + 1 + 10 + 1 好人有好报!你的热心我永远不忘!谢谢!
1342971816 + 1 + 1 评分=感恩!简单却充满爱!感谢您的作品!
凌云 + 6 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!
yf992151915 + 1 + 1 评分=感恩!简单却充满爱!感谢您的作品!
童真丶 + 6 + 1 评分=感恩!简单却充满爱!感谢您的作品!
Crook + 5 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!
阿辰 + 1 + 1 评分=感恩!简单却充满爱!感谢您的作品!
htqweszxc + 3 + 1 ★★★★★ 热心人,佛祖保佑你事事顺利 ,财源滚滚!!!

查看评分详情

学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 7

该用户今日未签到

学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 39

该用户今日未签到




这是干啥的。
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 338

该用户今日未签到




感谢分享peas的验证教程   学习学习思路
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 10

该用户今日未签到




OK 感觉不错。。。
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

该用户从未签到




收了200HB不错哟~!
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 3

该用户今日未签到




我也遇到过,不知道怎么弄
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 8

该用户今日未签到




试了一下伪造的DLL。发现提示程序已被非法修改。然后就自动退出了
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

签到天数: 4

该用户今日未签到




前排支持楼主的热心分享
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!

该用户从未签到




来学习一下
学破解论坛关注PC软件安全与移动软件安全领域。学习破解方法,使软件开发者能够更好的弥补软件缺陷,修复软件漏洞,提升软件安全,将损失降为最低。大量的软件加密解密教程,使软件开发者与代码逆向分析爱好者受益颇多,因此被连连称赞。保护开发者的利益与版权是我们持之以恒的动力!学破解论坛将竭尽全力为软件安全领域献出微薄之力!
您需要登录后才可以回帖 登录 | 立即注册

获得更多积分,阅读本版加分规则

免责声明

本站中所有被研究的素材与信息全部来源于互联网,版权争议与本站无关。本站所发布的任何软件的逆向分析文章、逆向分析视频、补丁、注册机和注册信息,仅限用于学习和研究软件安全的目的。全体用户必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。学习逆向分析技术是为了更好的完善软件可能存在的不安全因素,提升软件安全意识。所以您如果喜欢某程序,请购买注册正版软件,获得正版优质服务!不得将上述内容私自传播、销售或者其他任何非法用途!否则,一切后果请用户自负!

站长邮箱:SharkHeng#iCloud.com


站长微信号:SharkHeng|联系Email|鲨鱼逆向|无图版|手机版|小黑屋|FAQ|VIP破解教程|学破解论坛 ( 京公网安备 11011502002737号 | 京ICP备14042738号 ) 

GMT+8, 2019-10-15 22:35

快速回复 返回顶部 返回列表